Recent Changes - Search:


Code:


Social:


My journals will take the place of a blog. They have moved to https://goo.gl/JyZbSK


Sites I take responsibility for

Documents

Technical

General

Me

Living

Places I frequent

Hobbies

Humor

Items for sale:


Clipboard

edit SideBar

Apache fails to auto-start at boot from systemd using non-standard ports

Include our styles below Infobox - invoke as >>infobox<< ... >><<

Codebox: - invoke as >>codebox<< ... >><<

warnbox: - invoke as >>codebox<< ... >><<

editingbox: - invoke as >>codebox<< ... >><<

noticebox: - invoke as >>codebox<< ... >><<

Page bread crumbs:

Pages by tags: (:listtags:)
Subscribe to this wiki: RSS Feed RSS or subscribe to this page for changes: RSS Feed RSS
496 articles have been published so far. Recent changes
(:addThis btn="custom":)


>>> This page is not yet completed. <<<
>>> Last updated at June 27, 2014, at 09:47 PM EST. <<<
>>> Please check back later or hit refresh. <<<

Issue:

Release Fedora 20 with latest updates 2014-06-26.

(:code lang=Bash wrap=80:)

  1. uname -a

Linux xxxxxxxxxx 3.14.5-x86_64-linode42 #1 SMP Thu Jun 5 15:22:13 EDT 2014 x86_64 x86_64 x86_64 GNU/Linux (:codeend:)

After having installed Apache from yum (sudo yum install httpd httpd-devel httpd-tools), then configuring /etc/httpd/conf/httpd.conf but removing listener for port 80 and instead using multiple https ports other than 443 (intranet with a single IP) wit no iptables or SElinux running). To ensure Apache would restart on the next boot I used command

(:code lang=Bash wrap=80:)

  1. systemctl enable httpd.service

(:codeend:)

On system boot Apache fails to start with the following status from systemd:

(:code lang=Bash wrap=80:)

  1. systemctl status httpd -l

httpd.service - The Apache HTTP Server

   Loaded: loaded (/usr/lib/systemd/system/httpd.service; enabled)
   Active: failed (Result: exit-code) since Thu 2014-06-26 11:32:27 EDT; 3h 22min ago
  Process: 2380 ExecStop=/bin/kill -WINCH ${MAINPID} (code=exited, status=0/SUCCESS)
  Process: 2296 ExecStart=/usr/sbin/httpd $OPTIONS -DFOREGROUND (code=exited, status=1/FAILURE)
 Main PID: 2296 (code=exited, status=1/FAILURE)
   CGroup: /system.slice/httpd.service

Jun 26 11:32:27 web2 systemd[1]: Starting The Apache HTTP Server... Jun 26 11:32:27 web2 httpd[2296]: (99)Cannot assign requested address: AH00072: make_sock: could not bind to address 192.168.23.67:3287 Jun 26 11:32:27 web2 httpd[2296]: no listening sockets available, shutting down Jun 26 11:32:27 web2 httpd[2296]: AH00015: Unable to open logs Jun 26 11:32:27 web2 systemd[1]: httpd.service: main process exited, code=exited, status=1/FAILURE Jun 26 11:32:27 web2 systemd[1]: Failed to start The Apache HTTP Server. Jun 26 11:32:27 web2 systemd[1]: Unit httpd.service entered failed state. (:codeend:)

Note that I can manually start the service just fine either by using the command: # apachectl start or # service httpd start.

Apache's own configtest passes ok and the IP address exists and the ports are open and not being used by another process.

(:code lang=Bash wrap=80:)

  1. apachectl configtest

Syntax OK (:codeend:)

Notes:

https://fedoraproject.org/wiki/Systemd

/etc/systemd/system/multi-user.target.wants]


Kevin's Public Wiki maintained and created by Kevin P. Inscoe is licensed under a
Creative Commons Attribution 3.0 United States License.

Back to my web site - http://kevininscoe.com

Edit - History - Print - Recent Changes - Search
Page last modified on June 27, 2014, at 09:47 PM EST